항상 기분좋게 긍정적으로 스마일~


Posted
Filed under IT Story/Network







시스코(CISCO) 라우터 기본 명령어(필수위주)

 


키 정리

CTRL + A : 맨앞으로 이동, CTRL +  E: 맨 끝으로 이동

CTRL +  F : 앞으로 하나씩, CTRL + B: 뒤로 하나씩 이동

 

명령

설명

interface fastethernet 0/0.1

서브인터페이스를 만듬

interface serial 5

인터페이스 시리얼 5를 위한 환경설정모드로 전환시킴. show 명령과 함께 사용되기도함.

ip address

인터페이스상에 IP 어드레스를 설정

line

사용자모드 패스워드를 설정하거나 혹은 바꾸기 위한 환경설정모드로 전환시켜줌

line aux

보조인터페이스 환경설정 모드로 전환시켜줌

line console 0

콘솔 환경설정모드로 전환시켜줌

line vty

VTY(Telnet)인터페이스 환경설정모드로 이동시킴

logging synchronous

커맨드 라인 입력에 덮어쓰기를 막기 위해 콘솔메시지를 중지시킴

logout

콘솔세션을 로그아웃함

media-type

인터페이스상의 하드웨어 미디어 형식을 정함

no shutdown

인터페이스를 작동시킴

ping

IP Connectivity를 테스트함

router rip

라우터 rip 환경설정모드로 전환시켜줌

service password-encrypton

사용자모드와 enable password를 암호화함

show controllers s0

인터페이스의 DTE혹은 DCE상태를 보여줌

show history

디폴트로 지난 10번의 입력된 명령을 보여줌

show interface s0

인터페이스 시리얼 0의 통계를 보여줌

show run

show running config의 단축명령. 현재 라우터상에 구동중인 환경설정을 보여줌

show start

show startup-config의 단축명령. NVRAM내에 저장된 백업환경설정을 보여줌

show terminal

환경설정된 history size를 보여줌

show version

라우터의 통계를 보여줌

shutdown

인터페이스를 administratively-down 모드로 전환시켜줌

tab

여러분을 위한 명령어 입력을 끝냄

telnet

IP connectivity를 테스트하고 라우터를 환경 설정하는 명령

terminal history size

디폴트10인 history size를 256으로 바꿔줌

trace

IP 연결성을 테스트함

 ★1. The IOS and Its User Interface (P26)

CLI (Command Line Interface)-IOS로 작동되는 Cisco Routers와 Switches는 CLI를

통해 기본적인 환경설정을 한다. 한마디로~메뉴 방식이나 아이콘 방식이 아닌 껌정 화면에

명령어 입력 방식이라는 뜻이다.

 

★2. Router Component (P26)

 

☞RAM (Random-Acces Memory)-전원이 켜진 상태의 컴퓨터에 정보를 저장하는데 사용한다.

Cisco 라우터는 라우팅 테이블 그리고 NVRAM에 있는 하드웨어 어드레스 캐쉬에 있는 IOS를 저장

하기 위해 RAM을 사용한다. 한마디로 공연을 하기 위한 무대라고 생각하라...^^

O 임시적으로 Configuration file을 저장한다.(휘발성 메모리)

O Show running-config (같은 명령어=write term)- RAM의 Config를 확인하는 명령어

기타 RAM에서 작동되는 명령어

o show version

o show process cpu

o show mem

o show buffers           ====> 이런 것이 있다고 알고~ 꼭!!! 해봐라~^^

 

☞ROM (Read Only Memory)-이 칩은 장치의 부팅(순서)에 도움을 주기위해 컴퓨터에서 사용된다.

Cisco 라우터는 디폴트로 파워온 셀프 테스트를 실행하고, 플레쉬 메로리에서 IOS를 찾고 로드하기

위한 부트스트립 사용한다.

- Power On했을 경우 Boot strap Program, Os Software를 진단한다.

@ROM 기능 4가지

1> Boot Strap

2> POST (Power On Self Test)

3> Mini IOS : Flash의 IOS가 이상이 있을 때 작동된다. (기본적인 기능만 있다.)

4> Rom Monitor : Mini IOS가 이상이 있을 때 작동된다.

 

☞Flash : EEPROM-Electronically Erasable Programmable Read-Only Memory

- 전기적으로 지울 수 있는 프로그래머 읽기 전용 메모리....^^;

  한마디로 보통 롬은 지울 수 없지만 FLASH메모리는 자기가 원하는 작업 환경을 위해

  여러 가지를 사용한다는 뜻이다. 이건 쉽지...ㅋZ

- IOS Software image를 저장한다.

- IOS Software upgrade 또는 교체할 수 있다.

- show flash로 확인.

 

☞NVRAM (Nonvolatile RAM) – 비 휘발성 RAM

- Router Configuration File을 저장한다.

O show startup-config

O Router#erase startup-config ß--------NVRAM 파일 삭제

 

☞Interfaces = Network 연결

예) Cisco Router 2500기종의 Interfaces는 Ethernet Interface 1개, Serial Inerface 2개

-LAN interface : Ethernet, Fast-Ethernet, Token-Ring, FDDI

Serial interface : V.35 Cable, RS232C Cable등을 이용하여 DCE 장비로 접속된 후 전용선 혹은

공중선 인터넷과 통신할 수 있는 정보를 제공한다.

-DCE는 라우터와 라우터 간의 clock rate를 조절하여 패킷을 전송한다.

Show interface serial 0 의 명령어에서 보여줄 수 있는 예

1) Serial 0 is up , line protocol is up

- 정상적인 작동

2) Serial 0 is up , line protocol is down

- Clocking 혹은 Framing에 문제

- Clock rate 설정 안했을 경우 문제

- Option 설정의 문제

3) Serial 0 is down , line protocol is up

- Cable 이나 Interface 문제

4) Serial 0 is administratively down , line protocol is down

- Interface가 active 되지 않은 상태 – 어떻게 하냐구요.

- Router#config t ß-------- config terminal              ♦ ß= enter

- Router(config)#interface s0 ß-------- interface 환경설정 mode

- Router(config-if)#no shutdown ß-------- interface active 활성화~

- Router(config-if)#^Z ß- interface mode에서 privileged mode로 이동

- Router#copy running-config startup-config

 

★3. Command-Line Interface(CLI)

EXEC mode – Router의 Console(직접), AUX(모뎀), Telnet을 통해 Cisco IOS를 Access(접속)할 수 있다.

IOS 명령라인으로의 access를 EXEC 세션이라 부른다. EXEC 다른 프로그램의 수행을 제어하는 운영체제.

 

☞Telnet Password 설정방법

Router# conf t ß-------- 환경설정 mode로 이동

Router(config)# line vty 0 4 ß-------- Telnet 접속 터미널 정의

Router(config-line)# login ß-------- login 설정

Router(config-line)# password aaa ß-------- Password 설정

Router(config-line)# ^Z ß-------- ^Z or end

Router#copy running-config startup-config ß-------- RAM에서 NVRAM으로 이동

 

Router(config-line)#no login à Password를 입력하지 않고 라우터로 Telnet접속가능

Router(config-line)#exec-timeout 0 0 -> Telnet에 대한timeout을 0으로 세팅하거나

timeout이 발생하지 않도록 한다. 중요하진 않지만.. 알아두자~!!

O show user - 현제 활성화된 모든 콘솔포트와 VTY 포트를 보여준다.

O show session – 라우터와 원격 장치와의 연결을 확인하기 위한 명령어.

                   여러 라우터를 거친 목록을 확인할 수 있다.

O clear line 0 - 0번 터미널 접속자를 강제로 접속해지 시킨다.

O show session으로 나온 목록은 disconnect 명령어를 입력함으로써 목록을

               지울 수 있다.

 

☞Telnet으로 Router에 처음 접속했을 때 각 Mode

Password : aaa ß------ Telnet Pass를 물어온다.

Router> en ß----- User mode , enable을 입력한다.

Password : bbb ß----- enable Password or Secret Password를 입력한다.

Router#        ------- enable mode or privileged mode,

Router#config t ß----- config terminal

Router(config)# ----- global mode or configuration mode

Router(config)#int s 0 ß----- interface serial 0

Router(config-if)# ----- interface mode : interface의 환경설정 mode

Router(config-if)#^Z

Router#exit or logout ß-------- Telnet 접속 종료

 

☞각 mode에 대해 잠시 봅시다

Router> ? ß----- User mode 에서 ?를 치면 각 parameter를 볼수 있다.

ping

show

enable

기타등등 기본적인 show 기능과 Ping 기능을 지원합니다.

 

Router# -------enable mode or Privileged mode라고 한다.

User mode로 돌아가려면 disable을 입력하고 enter

기본적인 설정모드로 들어갈수 있는 mode라고 생각하면 된다.

 

☞암호화와 호스트 네임 변경.

Router#config t

Router(config)# ----- global mode or configuration mode라고 한다.

Router(config)#enable Password aaa ß----- enable password 입력

Router(config)#enable secret bbb ß----- secret password 입력

Secret는 암호화 password라고 하고 enable 보다 더 우선권이 있다.

Router(config)#hostname NRC ß------ hostname 변경

 

☞인터페이스 모드에서 설정 할것

NRC(config)#interface serial 0 ß------ interface mode로 들어가기

NRC(config-if)#no shutdown ß------ interface 활성화

NRC(config-if)#ip address 200.200.200.1 255.255.255.252 ß----ip address 입력

NRC(config-if)#bandwidth 1984 ß------ E1속도 지정

NRC(config-if)#encapsulation HDLC ß------ Cisco Router의 기본 설정

NRC(config-if)#description [test E1 서울-부산] ß-- interface에 대한 설명

이외에도 많은 interface 설정값들이 있답니다. 특정 interface의 고유한 값을

입력하는 곳이 interface mode입니다.

 

☞다양한 Config mode를 한번 볼까요

Router(config-if)# ß------ interface mode : Ethernet, Serial

Router(config-router)# ß------ Router mode : Routing Protocol에서 사용

Router(config-line)# ß----- Line mode : Console, Aux, Telnet

Router(Config-router-map)# ß------ Route Map mode

Router(config-subif)# ß------ Subinterface mode : 아주아주 중요

Router(config-controller)# ß------ Controller mode

위의 모드에서는 몇가지는 알지만 모르는 것도 있다. 암튼 이러한 것들이 있다는 건

알아야 할 것이다. 사실 나도 밑에 3가지는 사용 하지 않아서 잘~~^^;;

 

★4. Navigating The IOS CLI (쉽게 사용할 수 있는 기능)

☞이 파트에서는 ?, Tab, 단축키의 기능이 중요합니다.

하지만 시험 볼땐 단축키가 먹히지 않을 경우가 있으니 명령어 하나하나 다 치고 외우는 것이 좋다.

Router#show c? ß------- C로 시작되는 모든 단어를 보여준다.

Clear clock configure connect copy

Router#show cl ? ß------- cl ?를 하면 위에서 보듯이 cl로 시작되는 단어를 보여줌

Router#show cl을 실행 할 경우 두게 이상의 명령어가 존재하므로 아래와 같은 오류를 보여줌

%Ambiguous command 가 둘이기 때문에 애매한 명령어라는 오류발생...

Router#show clo + Tab ß------- clo로 시작되는 단어는 오직하나이기 때문에

Router#show clock ß------- 명령어 Full name을 보여준다.

Router#sh history ß------- 지금 까지 명령어를 수행했던 것을 default로 10개를 보여줌

En

Sh history

Show terminal

Sh int s 0

Sh flash

이런 식으로 보여준다.

Router#terminal history size ? ß-------- history buffer size를 조절가능

<0-256> size of history buffer

Router#terminal history size 20 ß-------- default 10에서 20으로 바꾸는 명령어

 

☞몇가지 알아두면 좋은 설정

-Clock rate 란 명령어 DCE Serial interface에 clocking을 제공하도록 설정

Router#config t

Router(config)#int s 0 ß--- DCE interface serial 0 환경설정으로 들어간다.

Router(config-if)#clock rate 64000 ß--- 64000으로 지정..

 

Router#sh controllers serial 0 ß-- 물리적 인터페이스 자체에 관한 정보를 표시한다.

 

★6. Configuration Pacesses and the Configuration file(P34)

Router(config-if)#Ctrl+Z or end ß-- interface mode에서 바로 privileged mode로 이동

Router#

Router(config-if)#exit ß-- interface mode에서 global mode로 이동

Router(config)#exit ß--- global mode에서 다시 privileged mode로 이동

Router#

 

★8. Managing Configuration file

Router#sh run ß--- show running-config(=write term) : RAM에 config확인

Router#sh start ß--- show startup-config(=show config) : NVRAM 확인

Router#erase startup-config ß--(=write erase) : NVRAM 설정 삭제

다양한 Copy 명령어 이해필요, 2가지 예

Router#copy tftp flash ß--- IOS upgrad때 사용

Router#copy start tftp ß--- NVRAM에 있는 file을 backup

 

☞중요한 개념 3개

Config terminal : 운영자를 global configuration mode로 보내고 running-config mode의

설정을 바꿈

Config memory : startup-config를 running-config로 복사 (=copy shartup run)

Config network : TFTP호스트에 저장된 설정을 running-config로 복사

 

Setup mode를 종료하고 싶을 때 : Ctrl+C

 

★9. Cisco Discovery Protocol – Layer2(Data link)계층의 작용

Cisco의 독자적인 프로토콜로서 인접한 Cisco장비에서 하드웨어 타입과 소프트웨어 버전, 그리고

Cisco 장비가 현재 사용하고 있는 활성화된 인터페이스에 대한 정보를 알려주는데 사용된다.

장비 간에는 SNAP(Subnetwork Access Protocol)프레임을 사용하며 라우팅은 할 수 없다.

(라우팅이란 패킷을 발신지부터 목적지까지 어떻게 보낼 것인가를 결정하는 기본적인 과정.)

Router#show cdp ß---- cdp 의 update 와 holdtime 시간을 알수 있다.

Global cdp information : (= show cdp interface)도 마찬가지

Sending CDP packets every 60 seconds ß-- default update 60초

        (기본 60초마다 아웃 라우터 확인)

Sending a holdtime value of 180 seconds ß-- default holdtime 180초

        (기본 180동안 연락 없음 삭제)

Router(config)#cdp timer 90 ß---- update 시간 조정

Router(config)#cdp holdtime 240 ß---- holdtime 시간조정

CDP는 모든 Cisco Router에 default로 enabled 되어있다.

Router(config)#cdp run ß---- global cdp enable 활성화!!

Router(config)#no cdp run ß---- global cdp disable 비활성화!!

위의 명령어는 라우터 전체의 CDP를 활성화 시키거나 비활성화 시키는 명령어.

Router(config-if)#cdp enable ß---- interface mode cdp enable

Router(config-if)#no cdp enable ß---- interface mode cdp disble

위의 명령어는 일정 인터페이스의 CDP만을 활성화 시키거나 비활성화 시키는 명령어.

Router#show cdp neighbor ß---- 직접적으로 연결된 장치의 정보를 보여준다.

Divice ID : 장치의 호스트명

Local interface : CDP 패킷을 받는 포트 or 인터페이스

Holdtime : CDP 패킷이 더 이상 들어오지 않을 때 , 라우터가 기존의 정보를

버리지 않고 유지할 수 있는 시간 시간이 다 지나면 삭제!!

Capability : 인접장치(라우터, 스위티, 리피터)의 Capability

Platform : Cisco 장치의 종류 Cisco 2500등

Port ID : CDP 패킷이 브로드캐스트 되는 인접장치의 포트나 인터페이스

Router#show cdp neighbor detail ß---- show cdp neighbor의 정보 + ip address

+ version (동일한 명령어 Router#show cdp entry )

암튼 show cdp neighbor보다 더 자세한 내용을 출력하는 명령어...^^

Router#show cdp traffic ß---- 인터페이스 트래픽 정보 – in, out CDP 패킷

및 에러값을 보여준다.(흐름을 보여준다. 예를 들어 56패킷을 보냈고 38패킷을 받았다.)

 

★알아두면 피가 되고 살이 되는 것

호스트 테이블 생성

ip host name tcp_port_number ip_address

Router(config)#ip host 2500 172.16.10.1

Router(config)#ip host switch 192.168.1..1

Router(config)#ip host NRC 211.211.211.1

Router#2500

Trying 2500 (172.16.10.1) ….. Open

User Access Verification

Password :

Router#sh hosts ß---------hosts table 보기

Router#NRC ß--------- NRC 라우터로 telnet 접속

Trying NRC (211.211.211.1)….. Open

User Access Venification

Password : 1234 ß-------- NRC Router의 telnet password

NRC#(conrol + shift + 6, then X) ß----- 다시 Router#로 돌아가고 싶을 때

Router# ß-------- 메인 콘솔로 되돌아 온다.

Router(config)#ip domain-lookup ß- default로 지정 : DNS를 통해서 호스트명을 찾는다.

Router(config)#no ip domain-lookup ß--- DNS에서 호스트명을 찾는 것을 방지

Router(config)#ip name-server 211.211.211.1 ß- DNS ip address지정 , 6개까지 가능

Router(config)#ip domain-name NRCkorea.com ß- 반드시 지정해야 한다.

 

 

★10. Managing IOS images

Cisco IOS를 upgrade 하거나 변경할 때 TFTP 호스트는 반드시 필요하다.

- IOS Upgrade -

Router#sh flash ß----- 현제의 flash memory 상태확인

C4500-d-mz.120-5.bin ß----- file name확인

[1481196 bytes used, 4207412 available, 8388608 total] ----8MB용량확인

사용하는 것과 사용할 수 있는 것을 더하면 토탈과 맞아야 하는데 이상하구먼... 암튼 이해바람...

Router#copy flash tftp ß----- flash file을 Tftp 호스트에 백업을 받아둔다.

Router#copy tftp flash ß----- 새로운 IOS를 Tftp에서 flash로 copy

Router#copy running-config tftp ß-- RAM의 file을 Tftp 호스트에 백업, 반대도 가능

Router#copy startup-config tftp ß-- NVRAM의 file을 Tftp 호스트에 백업, 반대도 가능

 

★11. Choosing Which IOS image to Load

Router 부팅과정

1) POST 과정을 수행한다. – 하드웨어 검사, 장치 및 인터페이스 이상유무 판별

2) bootstrap이 Cisco IOS 프로그램을 찾아서 불러들인다. – Flash로부터 up

3) IOS는 NVRAM에 저장된 환경설정 파일을 up

4) NVRAM에 파일이 없으면 Startup mode 실행

 

☞Configuration register : 환경설정 레지스터

- 16진수로 구성되어있고, 기본으로 0x2102로 구성 : 0x-뒷수가 16진수임을 의미

00 : ROM 모니터 모드 - 0x2100 , 라우터가 romon> 프롬프트를 보여준다.

01 : ROM으로부터 부트 이미지 – 0x2101, router(boot)> 프롬프트를 보여준다.

02-F : default 부트 파일이름을 지정 – 2102에서 210F의 값은 라우터가 NVRAM에

있는 부트 명령어를 사용하도록 알려준다.

Router#sh version ß--------- 환경설정 레지스터 값 확인

[ 생략 ]

configuration register is 0x2102

Router(config)#config-register 0x0101 ß--- 환경설정 레지스터 값 변경

Router(config)#^Z

몇가지 예

config-reg 0x2000 : RXBOOT (diagnostics mode, use ‘b’ to continue booting)진단 모드

config-reg 0x2101 : Boot to ROM, use NVRAM (upgrade flash in run-from-flash)

config-reg 0x2141 : Boot to ROM, skip NVRAM (disaster recovery)=손실 복구

config-reg 0x2102 : Boot to Flash, use NVRAM (normal operation)=표준

config-reg 0x2104 : Boot to Flash, skip NVRAM (password recovery)=패스워드 복구시

 

★12. Password Recovery

-Cisco Router의 경우 configuration 정보는 NVRAM(password포함)에 저장되고 default로

booting시에 NVRAM의 정보를 읽어들여서 현제 설정되어 있는 Password를 사용하게 된다.

이를 잃어버렸을 경우에는 booting시에 NVRAM정보를 무시하고 booting 하게 만든 후 새로운

password로 변경하여 저장하고 다시 booting하는 절차를 취해야 한다.

 

Cisco 2500 시리즈 예)

1) show version으로 레지스터값 확인

2) Power off -> on ß------- Use the power switch

3) 60초 이내에 (^+Break)를 누른뒤 엔터 ß----- 인터럽트 발생

4) >o/r42 ß------- rommon command 사용

5) > i ß------ initialize 기존의 저장된 configuration을 무시하고

(NVRAM무시)booting하게 된다.

6) “Would you like to enter the initial configuraton dialog ? NO ß-- setup mode무시

7) Router> en ß---- User mode에서 enable

8) Router#

(1) password를 볼수 있는 “show config”

(2) 기존의 config를 “wr erage”로 모두 삭제하는 방식

(3) password를 바꿀수 있는 commend

- Router#config memory ß-- NVRAM에 파일을 RAM으로 가져와서 config

- Router#config t

- Router(config)#enable secret aaa ß---- enable or secret pass 변경가능

- Router(config)#^Z

- Router#wr ß----- NVRAM에 저장

- Router#config t

_ Router#config-reg 0x2102 ß-원래의 configuration 레지스터값으로 복구

- Router(config)#^z

- Router#reload ß---- 새로 바꾼 password로 Router booting

- System configuration has been modified, save ? NO



 시스코라우터 환경설정

 시스코 Console cable pin assign 

 ROUTER(RJ45)                      PC(25pin)
     1  ----------------------  4  (RTS)
     2  ---------------------- 20 (DTR)
     3  ----------------------  2  (TXD)
     4  ----------------------  7  (S.G)
     6  ----------------------  3  (RXD)
     7  ----------------------  8  (DCD)
     8  ----------------------  5  (CTS)


 통신에뮬레이터 환경
     9600 bps, 8 data bit, 1 stop bit, parity none.

 시스코라우터 설정 특징
   Configuration Setting시 직접 Command를 입력하는 방법과 Router Power on 시
   H/W Test후 나타나는 Menu상에서 Configuration Setting 작업을 수행하는 Menu
   방식의 2가지 Mode가 제공된다.   Cisco Router의 경우 Command의 사용방법이
   매우 간결하므로, 직접 Command를 사용하여 Setting 작업을 수행하는 것이
   Menu방식에 비해 편리하므로 Command line방식 중심으로 설명코져 한다.

 시스코Configration설정방법

 기본적인 설정내용
   ① serial port 지정
     - ip address 설정
     - encapsulation 지정

   ② ethernet port 지정
     - ip address 설정

   ③ routing protocol 의 지정, 필요시 static routing 설정.

 라우터 설정예

  ex) 고객명 : 부산
      - router 기종 : cisco 2500
      - 접속 protocol : ppp , - 속도 : 512kbps
      - 고객측 serial ip, netmask : 210.248.102.100 / 255.255.255.252
      - 고객측 ethernet ip, netmask : 210.108.245.1 / 255.255.255.192

 시스코라우터 설정순서

pusan#config t -------- configuration terminal의 약어,  
                                     command setting mode로의 전환을 의미..

pusan(config)#
ip subnet-zero --------- ip block이 0(zero)로 시작하여 subneting
                                                            시킬 경우의 명령어

pusan(config)#
ip classless---------ip를 classless하게 사용하기 위한 명령어  
pusan(config)#
int e0  ------- ethernet port 설정을 시작한다.
pusan(config-if)#
no shutdown  ------
default 는 disable(shutdown) 상태이므로
                                                           이것을 enable 시킨다.

pusan(config-if)#
ip add 210.108.245.1 255.255.255.192 --- ethernet에 ip address를
                                                                                     지정한다.

pusan(coining-if)#
exit  ------- ethernet 설정을 마무리하고 다음 설정으로 넘어간다.
pusan(config)#
int s0  ------- serial port 설정을 시작한다.
pusan(config-if)#
no shutdown

pusan(config-if)#
ip add 210.248.102.100 255.255.255.252
pusan(config-if)#
encapsulation ppp  ------- 접속 protocol을 지정한다.(이기종간)
                                                                   cisco router끼리는 HDLC로 설정한다
.
pusan(config-if)#
bandwidth 512  ------- 접속 회선 속도를 설정한다.

pusan(config-if)#
description pusan
pusan(config-if)#
exit

pusan(config)#ip route 0.0.0.0 0.0.0.0 210.248.102.99  ------- default route를 구성한다.
pusan(config)#
ip name server 164.124.101.2  ------- domain name server를 지정한다.

pusan(config)#
^Z ------- Ctrl+Z를 눌러서 config mode를 종료한다.
pusan#
wr ------- save 한다.
####[OK]


  시스코라우터 설정상태보기

pusan# sh config    ------- show configration의 약자,
                                          configuration setting 상태의 확인.

Using 653 out of 32762 bytes
!
version 11.1 -------
현재 동작중인 router의 IOS Version을 나타낸다.
service udp-small-servers
service tcp-small-servers
!
hostname pusan -------
라우터의 이름을 나타낸다.( 접속시 prompt로 나타남.)
!
enable secret 5 $1$QZj/$NeE5rJCxLbdFUJUJ/CBcx0 -------
command mode로
                                                                                       전환되기 위한 password.

enable password router
!
!
interface Ethernet0
 ip address 203.233.10.5 255.255.255.0
!
interface Serial0
 ip address 203.252.12.10 255.255.255.252
 description pusan-woman-university
 encapsulation ppp -------
접속 protocol이 ppp임을 의미.
 bandwidth 512 -------
512K bps 의 전송속도를 의미.
!
interface Serial1
 no ip address
 shutdown  -------
관리자가 임의로 down, up 시킬 수 있으며 default는 shutdown 상태.
!
ip name-server 164.124.101.2 -------
domain-name server를 지정한다.
no ip classless
ip route 0.0.0.0 0.0.0.0 203.252.12.9 -------
default route를 지정한다.
snmp-server community public RO      
  destination은 상대 router serial port로 한다.
!
line con 0
line aux 0
line vty 0 4 -------
router에 telnet 접속을 허용하되 login의 절차를 거치고,
                             password는 router(임의 설정가능)로 한다.
                             (가상단말기 0-4까지 총5대의 접속을 허용)

password router            
login
!
end


출처 : 순배님의 블로그http://blog.naver.com/ybtmglty




2011/05/20 13:51 2011/05/20 13:51